Skip to main content
Published: October 25 2006, 12:20:00 PMUpdated: November 28 2020, 2:56:13 PM

I am trying to set the ShippingType to Free in my AddItem request, but it does not let me add any ShippingService. Why is this happening?

Summary

The ShippingCodeType Free is not meant to be used as an input.  If you set ShippingType to Free, it will not allow you to specify any ShippingService and on the Search or ViewItem page, it does not show that Shipping is Free anywhere unless you specify it in the description. 
 



Detailed Description

If you need to specify the Shipping Cost as Free, then you need to set the ShippingServiceCost to 0 as under:

<?xml version="1.0" encoding="utf-8"?>
<
AddItemRequest xmlns="urn:ebay:apis:eBLBaseComponents">
  <
WarningLevel>High</WarningLevel>
  <
Version>483</Version>
  <
Item>
    <
Country>US</Country>
    <
Currency>USD</Currency>
    <
Description>description</Description>
    <
ListingDuration>Days_7</ListingDuration>
    <
Location>San Jose, CA</Location>
    <
PaymentMethods>PaymentSeeDescription</PaymentMethods>
    <
PrimaryCategory>
      <
CategoryID>30120</CategoryID>
    </
PrimaryCategory>
    <
Quantity>1</Quantity>
    <
StartPrice>1.0</StartPrice>
    <
Title>title</Title>
    <
ShippingDetails>
      <
ShippingServiceOptions>
        <
ShippingServicePriority>1</ShippingServicePriority>
        <
ShippingService>UPS2ndDay</ShippingService>
        <
ShippingServiceCost>0</ShippingServiceCost>
      </
ShippingServiceOptions>
    </
ShippingDetails>
  </
Item>
  <
RequesterCredentials>
    <
eBayAuthToken>*****</eBayAuthToken>
  </
RequesterCredentials>
</
AddItemRequest>

The documentation will be updated shortly to show the ShippingCodeType Free as output only.


Version Info

The code example above was based on the versions specified below:

API Schema Version 483



Additional Resources

How well did this answer your question?
Answers others found helpful