Skip to main content
Published: June 30 2005, 12:00:00 AMUpdated: November 28 2020, 1:26:34 PM

I am getting an error that says "No ShipToLocation selected" even though I clearly have a ShipToLocations specified in the AddItem call.

or

I am trying to use ShippingServices in my AddItem call, but I am getting back errors about ShipToLocation.

When listing with ShippingServiceOptions, make sure that the Domestic Shipping Service Options do not mistakenly have an International ShippingService. If you accidentally indicate an International ShippingService in a Domestice ShippingServiceOptions container, you may get back errors about missing ShipToLocations. An example of this mistake is to include the following (note the ShippingService "ExpeditedInternational" used in a Domestic ShippingServiceOptions container) in your AddItem request:

<ShipToLocations>US</ShipToLocations>
<ShippingDetails>
<PaymentInstructions>Please do not use eBay Checkout. Buyer/winner can use checkout button in this listing or respond to instructions sent via email after the listing closes.</PaymentInstructions>
<ShippingServiceOptions>
<ShippingService>ShippingMethodStandard</ShippingService>
<ShippingServiceCost>2.95</ShippingServiceCost>
<ShippingServiceAdditionalCost>0.8</ShippingServiceAdditionalCost>
<ShippingServicePriority>1</ShippingServicePriority>
</ShippingServiceOptions>
<ShippingServiceOptions>
<ShippingService>ExpeditedInternational</ShippingService>
<ShippingServiceCost>16.3</ShippingServiceCost>
<ShippingServiceAdditionalCost>14.15</ShippingServiceAdditionalCost>
<ShippingServicePriority>2</ShippingServicePriority>
</ShippingServiceOptions>
</ShippingDetails>

An AddItem call with the above XML may very well return this kind of error:

<?xml version="1.0" encoding="UTF-8" ?>
<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsd="http://www.w3.org/2001/XMLSchema" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance">
<soapenv:Body>
<AddItemResponse xmlns="urn:ebay:apis:eBLBaseComponents">
<Timestamp>2005-05-31T18:38:59.641Z</Timestamp>
<Ack>Failure</Ack>
<CorrelationID>00000000-00000000-00000000-00000000-00000000-00000000-0000000000</CorrelationID>
<Errors>
<ShortMessage>No ShipToLocation selected.</ShortMessage>
<LongMessage>You must specify at least one shipping location.</LongMessage>
<ErrorCode>17509</ErrorCode>
<SeverityCode>Error</SeverityCode>
<ErrorClassification>RequestError</ErrorClassification>
</Errors>
<Version>409</Version>
<Build>20050516181557</Build>
</AddItemResponse>
</soapenv:Body>
</soapenv:Envelope>

How well did this answer your question?
Answers others found helpful