Skip to main content
Published: September 04 2006, 2:44:00 PMUpdated: November 28 2020, 2:30:56 PM

AddMemberMessageAAQToPartner returns 'Message contains invalid syntax'. Here is my request:

<?xml version='1.0' encoding='utf-8'?>
   <AddMemberMessageAAQToPartnerRequest  xmlns="urn:ebay:apis:eBLBaseComponents">
     <RequesterCredentials>
     <eBayAuthToken>Your Token</eBayAuthToken>
     </RequesterCredentials>
     <ItemID>12345678909</ItemID>
     <MemberMessage>
     <MessageType>ContactTransactionPartner</MessageType>
     <QuestionType>General</QuestionType>
     <Subject>test</Subject>
     <Body><![CDATA[Thanks for buying the item 1234567688 that titled "Test Auction Title"  ]]></Body>
     <RecipientID>testaccount</RecipientID>
   </MemberMessage>
</AddMemberMessageAAQToPartnerRequest>

Detail Description

 The error is triggered by the double quotation that included inside the Body tag. 

 Even though double quotation is a legal XML characters by W3 definition, it is not allowed in the Message in both the eBay API calls and the site.  You need to replace the quotation with entity reference&quot;  as showing in the follow request:

<?xml version='1.0' encoding='utf-8'?>
   <AddMemberMessageAAQToPartnerRequest  xmlns="urn:ebay:apis:eBLBaseComponents">
     <RequesterCredentials>
     <eBayAuthToken>Your Token</eBayAuthToken>
     </RequesterCredentials>
     <ItemID>12345678909</ItemID>
     <MemberMessage>
     <MessageType>ContactTransactionPartner</MessageType>
     <QuestionType>General</QuestionType>
     <Subject>test</Subject>
     <Body><![CDATA[Thanks for buying the item 1234567688 that titled &quot;Test Auction Title&quot; ]]></Body>
     <RecipientID>testaccount</RecipientID>
   </MemberMessage>
</AddMemberMessageAAQToPartnerRequest>

How well did this answer your question?
Answers others found helpful