Skip to main content
Published: June 19 2012, 3:45:00 PMUpdated: November 28 2020, 10:32:06 PM

 I am getting 'Invalid Bid' error in the PlaceOffer api response.  Why ?

 

There can be different reason for this error.

case 1 :

You listed an item with via AddItem api and set <BuyItNowPrice>11.789</BuyItNowPrice>. Now you made the follwoing PlaceOffer call
<?xml version="1.0" encoding="utf-8"?>
<PlaceOfferRequest xmlns="urn:ebay:apis:eBLBaseComponents">
  <ErrorLanguage>en_US</ErrorLanguage>
  <RequesterCredentials>
    <eBayAuthToken>*****</eBayAuthToken>  
</RequesterCredentials>
  <ItemID>110100142859</ItemID>
  <Offer>
    <Action>Purchase</Action>
    <Quantity>1</Quantity>
    <MaxBid currencyID="USD">11.789</MaxBid>
  </Offer>
</PlaceOfferRequest>

and got the 'Invalid Bid' error.

Sol : So when you made the AddItem call with 11.789, the amount got rounded off to 11.79 and since you are making the PlaceOffer api request with 11.789, it throws an error.

Since the Action has been set to 'Purchase', the amount has to be exactlty same as the Buy it Now price which is now 11.79, not 11.789. The amount can be checked on web or via GetItem api call.

case 2:
The other common mistake can be while  setting up the <Action> tag value. For 'Purchase', it has to be exactly same as the buy it now price. If you have set the value as 'purchase' and give a price less than the Buy It Now price, it will throw an error. You should set the <Action> tag value as 'Bid', if you intend to place an offer which is less than Buy It Now price.

How well did this answer your question?
Answers others found helpful