Skip to main content
Published: December 16 2011, 4:12:00 PMUpdated: November 28 2020, 10:09:59 PM

How come I am not recieving all my platform notifications?

Summary

How to set the version of the API calls that come from platform notifications.



Detailed Description

Platform notifications are triggered by events on the eBay site, and data in those notifications comes from making an eBay API call.  If you do not have the proper version set, the API call can fail causing the user not to receieve the notifications.  By default, the API version for notifications will be based on the API version specified in your first SetNotificationPreferences call.  To change the version, you will need to set the PayloadVersion when making a SetNotificationPreferences.  To check which version you currently have, make a call to GetNotificationPreferences.  Here is an example:

<?xml version="1.0" encoding="utf-8"?>
<GetNotificationPreferencesRequest xmlns="urn:ebay:apis:eBLBaseComponents">
  <ns1:Version xmlns:ns1="urn:ebay:apis:eBLBaseComponents">729</ns1:Version>
  <!-- choose either User or Application -->
  <PreferenceLevel>Application</PreferenceLevel>
  <RequesterCredentials>
    <eBayAuthToken>XXX</eBayAuthToken>
  </RequesterCredentials>
</GetNotificationPreferencesRequest>



Additional Resources

SetNotificationPreferences: http://developer.ebay.com/DevZone/XML/docs/Reference/eBay/SetNotificationPreferences.html

ApplicationDeliveryPreferences
  .PayloadVersion: http://developer.ebay.com/DevZone/XML/docs/Reference/eBay/SetNotificationPreferences.html#Request.ApplicationDeliveryPreferences.PayloadVersion

GetNotificationPreferences: http://developer.ebay.com/DevZone/XML/docs/Reference/eBay/GetNotificationPreferences.html

How well did this answer your question?
Answers others found helpful