Skip to main content
Published: April 25 2011, 11:49:00 AMUpdated: November 28 2020, 9:23:18 PM

I was getting the error "Token has hard-expired" when making API calls. So I generated a new token. However, when I make a call to GetStore I am getting the following error - "User must have a store subscription".

My eBay user is subscribed to a store. Why am I getting this error?

It is possible that the newly generated token was not for the eBay user with the stores subscription. A quick way to troubleshoot the issue would be to make a call to GetUser (see below) using this new token. The response will indicate the eBay user associated with the token.

<?xml version="1.0" encoding="utf-8"?>
<GetUserRequest xmlns="urn:ebay:apis:eBLBaseComponents">
  <RequesterCredentials>
    <eBayAuthToken>token</eBayAuthToken>
  </RequesterCredentials>
</GetUserRequest>

How well did this answer your question?
Answers others found helpful