eBay Client Alerts APIVersion 963

Errors by Number

This table lists all error and warning messages that could be encountered using the eBay ClientAlerts API. A tip: Most HTML browsers support text search of the displayed document, typically initiated with Ctrl-F. Use this to search for an ID or for text of an error or warning message returned by a call.

All error messages are provided in English only. You can use the ID as an index into your own structure for supplying messages in whatever language or format you wish, but base your message translations on the error strings in this table.

You see "replaceable_value" in several messages in this table. It is simply a placeholder. At run-time, an actual value is returned, a value whose meaning depends on the context of the error message.

Errors are divided into two types, System Error and Request Error. This error type is indicated in error result sets by the value returned in the ErrorClass return field. The error type indicates what sort of action the application, the developer, or the end-user needs to take in response to the error.

Error 1.11 ("Internal error to the application") reflects an error on the eBay server side, not an error in your application.

The version number in the heading (which indicates which eBay ClientAlerts API version that was in effect when this table was last generated) may be higher than the version of the WSDL you are using. This is because the list of possible errors can change periodically even though the WSDL may not change (due to changes in validation rules on the eBay site).

ID Severity Short Message Long Message Classification
1.10 Error Web Service framework internal error. Web Service framework internal error. RequestError
1.11 Error Internal error to the application. Internal error to the application. RequestError
1.12 Error Unknown Error. Unknown Error. RequestError
1.13 Error Unsupported verb. The API verb is not supported in this release. RequestError
1.14 Error Unsupported error level. The specified API error level is unsupported in this release. RequestError
1.15 Warning Invalid value. Tag has invalid value. SystemError
1.16 Warning Conversion failed at xpath. Conversion failed at xpath. SystemError
1.17 Warning Data error. Data error. SystemError
1.18 Error Invalid callname in the request Url. The callname in the request URL does not match the RequestType. RequestError
1.19 Error Missing required input element. Required input element is missing from the request. RequestError
1.20 Error Application ID invalid. Application ID invalid. RequestError
1.21 Error IP limit exceeded. Applications from this IP address are limited in the number of calls they can make. RequestError
1.22 Error Input data is invalid. Input data for the given tag is invalid or missing. Please check API documentation. RequestError
1.23 Error The request timed out. The request timed out. The response may contain too many items. Try a more specific query. SystemError
1.24 Warning Aborted by handler. Request process aborted by a handler. SystemError
1.25 Error Missing required call name. Missing required call name. Please specify as URL parameter or HTTP header. RequestError
1.26 Error Missing required application ID. Missing required application ID. Please specify as URL parameter or HTTP header. RequestError
1.27 Error Missing required version. Missing required version. Please specify as URL parameter or HTTP header. RequestError
1.28 Error Version invalid. Invalid version specified in URL parameter or HTTP header. RequestError
1.29 Warning Version specified is below minimum version. Version specified is below minimum version. Setting version to minimum version for the service. RequestError
1.30 Warning Version specified is above current version. Version specified is above current version. Setting version to current release version. RequestError
1.31 Error JSON Callback name specified is invalid. JSON Callback name specified is invalid. Callback name can contain alphanumeric, underscore, dash, and dot characters only. RequestError
11.1 Error Invalid ClientAlerts Auth Token. The ClientAlerts Auth Token that you provided is not valid. RequestError
11.2 Error ClientAlerts Auth Token has expired. The ClientAlerts Auth Token that you provided has expired. RequestError
11.3 Error Session has expired. Your current session has expired. Please login again to create a new session. RequestError
11.4 Error Invalid Session ID. The session ID that you provided is not valid. RequestError
11.5 Error There are currently too many simultaneous users on the system. There are currently too many simultaneous users on the system. Please try again later. RequestError
11.6 Error You currently have too many active sessions. You currently have too many active sessions. Please logout on any sessions that do not need and try to login again. RequestError
11.7 Error Poll rate too high. You have submitted too many requests per second. RequestError
11.8 Error Invalid Session ID. The session data string that you provided is not valid. RequestError
11.9 Error Unable to deserialize input. The request string is not in the correct format. Please check the schema. RequestError